Juniper Junos RPD MPLS RCE (JSA10877)

High Nessus Plugin ID 118231

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

According to its self-reported version number, the remote Junos device is affected by a potential remote code execution vulnerability due to how the routing protocol daemon handles MPLS packets. An attacker could potentially crash the RDP service or execute code.

Solution

Apply the relevant Junos software release referenced in Juniper advisory JSA10877.

See Also

https://kb.juniper.net/InfoCenter/index?page=content&id=JSA10877

Plugin Details

Severity: High

ID: 118231

File Name: juniper_jsa10877.nasl

Version: 1.5

Type: combined

Published: 2018/10/19

Updated: 2019/01/18

Dependencies: 55932

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-0043

CVSS Score Rationale: Based on vendor advisory.

CVSS v2.0

Base Score: 8.3

Vector: CVSS2#AV:A/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/o:juniper:junos

Required KB Items: Host/Juniper/JUNOS/Version, Host/Juniper/model

Patch Publication Date: 2018/10/10

Vulnerability Publication Date: 2018/10/10

Reference Information

CVE: CVE-2018-0043

JSA: JSA10877