Debian DSA-4320-1 : asterisk - security update

Medium Nessus Plugin ID 118158

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities have been discovered in Asterisk, an open source PBX and telephony toolkit, which may result in denial of service or information disclosure.

Solution

Upgrade the asterisk packages.

For the stable distribution (stretch), these problems have been fixed in version 1:13.14.1~dfsg-2+deb9u4.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=891227

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=891228

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=902954

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=909554

https://security-tracker.debian.org/tracker/source-package/asterisk

https://packages.debian.org/source/stretch/asterisk

https://www.debian.org/security/2018/dsa-4320

Plugin Details

Severity: Medium

ID: 118158

File Name: debian_DSA-4320.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2018/10/17

Updated: 2019/04/05

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:asterisk, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/10/16

Reference Information

CVE: CVE-2018-12227, CVE-2018-17281, CVE-2018-7284, CVE-2018-7286

DSA: 4320