nginx Data Disclosure Vulnerability

Medium Nessus Plugin ID 118151

Synopsis

The remote web server is affected by a data disclosure vulnerability.

Description

According to its Server response header, the installed version of nginx is 1.12.x prior to 1.12.1 or 1.13.x prior to 1.13.3. It is, therefore, affected by a data disclosure vulnerability.

Solution

Either apply the patch manually or upgrade to nginx 1.12.1 / 1.13.3 or later.

See Also

http://nginx.org/en/security_advisories.html

http://mailman.nginx.org/pipermail/nginx-announce/2017/000200.html

Plugin Details

Severity: Medium

ID: 118151

File Name: nginx_1_13_3.nasl

Version: 1.1

Type: remote

Family: Web Servers

Published: 2018/10/16

Updated: 2018/10/16

Dependencies: 106375

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2017-7529

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Patch Publication Date: 2017/07/22

Vulnerability Publication Date: 2017/07/11

Reference Information

CVE: CVE-2017-7529

BID: 103938