nginx < 1.10.1 / 1.11.x < 1.11.1 Denial-of-Service Vulnerability

Medium Nessus Plugin ID 118150


The remote web server is affected by a denial of service vulnerability.


According to the self-reported version in its response header, the version of nginx hosted on the remote web server is less than 1.10.1, or 1.11.x less than 1.11.1. It is, therefore, affected by a denial of service vulnerability


Upgrade to nginx version 1.10.1 / 1.11.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 118150

File Name: nginx_1_11_1.nasl

Version: 1.1

Type: remote

Family: Web Servers

Published: 2018/10/16

Updated: 2018/10/16

Dependencies: 106375

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2016-4450

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Patch Publication Date: 2017/07/11

Vulnerability Publication Date: 2017/07/11

Reference Information

CVE: CVE-2016-4450

BID: 90967