Debian DSA-4316-1 : imagemagick - security update

high Nessus Plugin ID 118098

Synopsis

The remote Debian host is missing a security-related update.

Description

This update fixes several vulnerabilities in Imagemagick, a graphical software suite. Various memory handling problems or incomplete input sanitising have been found in the coders for BMP, DIB, PICT, DCM, CUT and PSD.

Solution

Upgrade the imagemagick packages.

For the stable distribution (stretch), these problems have been fixed in version 8:6.9.7.4+dfsg-11+deb9u6.

See Also

https://security-tracker.debian.org/tracker/source-package/imagemagick

https://packages.debian.org/source/stretch/imagemagick

https://www.debian.org/security/2018/dsa-4316

Plugin Details

Severity: High

ID: 118098

File Name: debian_DSA-4316.nasl

Version: 1.5

Type: local

Agent: unix

Published: 10/15/2018

Updated: 2/8/2022

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2018-16413

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:imagemagick, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 10/12/2018

Vulnerability Publication Date: 9/3/2018

Reference Information

CVE: CVE-2018-16412, CVE-2018-16413, CVE-2018-16642, CVE-2018-16644, CVE-2018-16645

DSA: 4316