Debian DSA-4314-1 : net-snmp - security update

High Nessus Plugin ID 118071

Synopsis

The remote Debian host is missing a security-related update.

Description

Magnus Klaaborg Stubman discovered a NULL pointer dereference bug in net-snmp, a suite of Simple Network Management Protocol applications, allowing a remote, authenticated attacker to crash the snmpd process (causing a denial of service).

Solution

Upgrade the net-snmp packages.

For the stable distribution (stretch), this problem has been fixed in version 5.7.3+dfsg-1.7+deb9u1.

See Also

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=910638

https://security-tracker.debian.org/tracker/net-snmp

https://packages.debian.org/source/stretch/net-snmp

http://www.debian.org/security/2018/dsa-4314

Plugin Details

Severity: High

ID: 118071

File Name: debian_DSA-4314.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/10/12

Modified: 2018/10/12

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:net-snmp, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/10/11

Reference Information

CVE: CVE-2018-18065

DSA: 4314