Debian DLA-1542-1 : dnsruby update

High Nessus Plugin ID 118070

Synopsis

The remote Debian host is missing a security update.

Description

dnsruby is a feature-complete DNS(SEC) client for Ruby. It ships the DNS Root Key Signing Key (KSK), used as trust anchor to validate the authenticity of DNS records. This update includes the latest KSK (KSK-2017), that will be used by ICANN to sign the Root Zone today, 11 October 2018.

For Debian 8 'Jessie', this problem has been fixed in version 1.54-2+deb8u1.

We recommend that you upgrade your dnsruby packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected ruby-dnsruby package.

See Also

https://lists.debian.org/debian-lts-announce/2018/10/msg00004.html

https://packages.debian.org/source/jessie/dnsruby

Plugin Details

Severity: High

ID: 118070

File Name: debian_DLA-1542.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/10/12

Modified: 2018/10/12

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ruby-dnsruby, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/10/11