Fedora 27 : php-tcpdf (2018-187e212568)

High Nessus Plugin ID 117925

Synopsis

The remote Fedora host is missing a security update.

Description

**Version 6.2.25**

- Fix support for image URLs.

----

**Version 6.2.24**

- Support remote urls when checking if file exists.

----

**Version 6.2.23**

- Simplify file_exists function.

----

**Version 6.2.20**

- Fix for security vulnerability: Using the phar://
wrapper it was possible to trigger the unserialization
of user provided data.

----

**Version 6.2.19**

- Merge various fixes for PHP 7.3 compatibility and
security.

Note that Tenable Network Security has extracted the preceding
description block directly from the Fedora update system website.
Tenable has attempted to automatically clean and format it as much as
possible without introducing additional issues.

Solution

Update the affected php-tcpdf package.

See Also

https://bodhi.fedoraproject.org/updates/FEDORA-2018-187e212568

Plugin Details

Severity: High

ID: 117925

File Name: fedora_2018-187e212568.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/10/05

Modified: 2018/10/05

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:php-tcpdf, cpe:/o:fedoraproject:fedora:27

Patch Publication Date: 2018/10/04

Reference Information