Debian DLA-1530-1 : imagemagick security update

High Nessus Plugin ID 117907

Synopsis

The remote Debian host is missing a security update.

Description

Several security vulnerabilities were discovered in ImageMagick, an image manipulation program, that allow remote attackers to cause denial of service (application crash, excessive memory allocation, or other unspecified effects) or out of bounds memory access via DCM, PWP, CALS, PICT, BMP, DIB, or PNG image files.

For Debian 8 'Jessie', these problems have been fixed in version 8:6.8.9.9-5+deb8u14.

We recommend that you upgrade your imagemagick packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/10/msg00002.html

https://packages.debian.org/source/jessie/imagemagick

Plugin Details

Severity: High

ID: 117907

File Name: debian_DLA-1530.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/10/04

Modified: 2018/10/04

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:imagemagick, p-cpe:/a:debian:debian_linux:imagemagick-6.q16, p-cpe:/a:debian:debian_linux:imagemagick-common, p-cpe:/a:debian:debian_linux:imagemagick-dbg, p-cpe:/a:debian:debian_linux:imagemagick-doc, p-cpe:/a:debian:debian_linux:libimage-magick-perl, p-cpe:/a:debian:debian_linux:libimage-magick-q16-perl, p-cpe:/a:debian:debian_linux:libmagick++-6-headers, p-cpe:/a:debian:debian_linux:libmagick++-6.q16-5, p-cpe:/a:debian:debian_linux:libmagick++-6.q16-dev, p-cpe:/a:debian:debian_linux:libmagick++-dev, p-cpe:/a:debian:debian_linux:libmagickcore-6-arch-config, p-cpe:/a:debian:debian_linux:libmagickcore-6-headers, p-cpe:/a:debian:debian_linux:libmagickcore-6.q16-2, p-cpe:/a:debian:debian_linux:libmagickcore-6.q16-2-extra, p-cpe:/a:debian:debian_linux:libmagickcore-6.q16-dev, p-cpe:/a:debian:debian_linux:libmagickcore-dev, p-cpe:/a:debian:debian_linux:libmagickwand-6-headers, p-cpe:/a:debian:debian_linux:libmagickwand-6.q16-2, p-cpe:/a:debian:debian_linux:libmagickwand-6.q16-dev, p-cpe:/a:debian:debian_linux:libmagickwand-dev, p-cpe:/a:debian:debian_linux:perlmagick, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/10/03

Reference Information

CVE: CVE-2018-16412, CVE-2018-16413, CVE-2018-16642, CVE-2018-16643, CVE-2018-16644, CVE-2018-16645, CVE-2018-16749