DNN (DotNetNuke) 5.0.0 < 9.2.2 Multiple Vulnerabilities

Medium Nessus Plugin ID 117884

Synopsis

The remote web server contains an ASP.NET application that is affected by multiple vulnerabilities.

Description

The version of DNN Platform (formerly DotNetNuke) running on the remote host is 5.0.0 or later but prior to 9.2.2. It is, therefore, affected by multiple vulnerabilities including a leaked cryptographic information vulnerability and a cross-site scripting vulnerability.
An authenticated attacker could leverage these vulnerabilities to gain additional unintended access.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to DNN Platform version 9.2.2 or later.

See Also

https://www.dnnsoftware.com/community/security/security-center

Plugin Details

Severity: Medium

ID: 117884

File Name: dotnetnuke_9_2_2.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2018/10/02

Modified: 2018/10/03

Dependencies: 42978

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Authenticated cryptographic issue allowing authentication bypass

CVSS v2.0

Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS v3.0

Base Score: 6.3

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:dotnetnuke:dotnetnuke

Required KB Items: installed_sw/DNN

Patch Publication Date: 2018/10/01

Vulnerability Publication Date: 2018/10/01