Asterisk 13.x < 13.23.1 / 14.x < 14.7.8 / 15.x < 15.6.1 / 13.21 < 13.21-cert3 HTTP Websocket Stack Overflow (AST-2018-009)

Medium Nessus Plugin ID 117808

Synopsis

A telephony application running on the remote host is affected by a remote denial of service vulnerability.

Description

According to its SIP banner, the version of Asterisk running on the remote host is 13.x prior to 13.23.1, 14.x prior to 14.7.8, 15.x prior to 15.6.1, or 13.21 prior to 13.21-cert3. It is therefore, affected by an error related to the res_http_websocket.so module that allows a stack overflow error as described in AST-2018-009. This error can allow denial of service attacks.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Asterisk version 13.23.1 / 14.7.8 / 15.6.1 / 13.21-cert3 or later.

Alternatively, do not load the res_http_websocket.so module, thus disabling HTTP websocket access.

See Also

http://downloads.asterisk.org/pub/security/AST-2018-009.html

https://issues.asterisk.org/jira/browse/ASTERISK-28013

Plugin Details

Severity: Medium

ID: 117808

File Name: asterisk_ast_2018_009.nasl

Version: 1.1

Type: remote

Family: Misc.

Published: 2018/09/27

Modified: 2018/09/27

Dependencies: 63202

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Denial of service

CVSSv2

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSSv3

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Patch Publication Date: 2018/09/20

Vulnerability Publication Date: 2018/09/20

Reference Information

CVE: CVE-2018-17281

IAVA: 2018-A-0304