Asterisk 13.x < 13.23.1 / 14.x < 14.7.8 / 15.x < 15.6.1 / 13.21 < 13.21-cert3 HTTP Websocket Stack Overflow (AST-2018-009)

Medium Nessus Plugin ID 117808


A telephony application running on the remote host is affected by a remote denial of service vulnerability.


According to its SIP banner, the version of Asterisk running on the remote host is 13.x prior to 13.23.1, 14.x prior to 14.7.8, 15.x prior to 15.6.1, or 13.21 prior to 13.21-cert3. It is therefore, affected by an error related to the module that allows a stack overflow error as described in AST-2018-009. This error can allow denial of service attacks.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Asterisk version 13.23.1 / 14.7.8 / 15.6.1 / 13.21-cert3 or later.

Alternatively, do not load the module, thus disabling HTTP websocket access.

See Also

Plugin Details

Severity: Medium

ID: 117808

File Name: asterisk_ast_2018_009.nasl

Version: 1.4

Type: remote

Family: Misc.

Published: 2018/09/27

Updated: 2019/11/01

Dependencies: 63202

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-17281

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/09/20

Vulnerability Publication Date: 2018/09/20

Reference Information

CVE: CVE-2018-17281