Asterisk 13.x < 13.23.1 / 14.x < 14.7.8 / 15.x < 15.6.1 / 13.21 < 13.21-cert3 HTTP Websocket Stack Overflow (AST-2018-009)
Medium Nessus Plugin ID 117808
SynopsisA telephony application running on the remote host is affected by a remote denial of service vulnerability.
DescriptionAccording to its SIP banner, the version of Asterisk running on the remote host is 13.x prior to 13.23.1, 14.x prior to 14.7.8, 15.x prior to 15.6.1, or 13.21 prior to 13.21-cert3. It is therefore, affected by an error related to the res_http_websocket.so module that allows a stack overflow error as described in AST-2018-009. This error can allow denial of service attacks.
Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
SolutionUpgrade to Asterisk version 13.23.1 / 14.7.8 / 15.6.1 / 13.21-cert3 or later.
Alternatively, do not load the res_http_websocket.so module, thus disabling HTTP websocket access.