Apache 2.4.x < 2.4.35 DoS

Medium Nessus Plugin ID 117807

Synopsis

The remote web server is affected by a denial of service vulnerability.

Description

According to its banner, the version of Apache running on the remote host is 2.4.x prior to 2.4.35. It is, therefore, affected by the following vulnerability:

- By sending continuous SETTINGS frames of maximum size an ongoing HTTP/2 connection could be kept busy and would never time out. This can be abused for a DoS on the server. This only affect a server that has enabled the h2 protocol.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache version 2.4.35 or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.35

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.35

Plugin Details

Severity: Medium

ID: 117807

File Name: apache_2_4_35.nasl

Version: 1.2

Type: remote

Family: Web Servers

Published: 2018/09/27

Modified: 2018/10/04

Dependencies: 48204

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Vulnerabilities not yet scored by nvd

CVSSv2

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSSv3

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:apache:http_server, cpe:/a:apache:httpd

Required KB Items: installed_sw/Apache

Patch Publication Date: 2018/09/25

Vulnerability Publication Date: 2018/09/25

Reference Information

CVE: CVE-2018-11763

IAVA: 2018-A-0310