EulerOS 2.0 SP3 : binutils (EulerOS-SA-2018-1284)

Medium Nessus Plugin ID 117728

Synopsis

The remote EulerOS host is missing multiple security updates.

Description

According to the versions of the binutils packages installed, the
EulerOS installation on the remote host is affected by the following
vulnerabilities :

- A vulnerability was found in the readelf utility; part
of binutils. A crafted ELF executable or shared library
could cause readelf to write arbitrary locations on the
heap while processing relocations, leading to a crash
or potential code execution.(CVE-2017-6965)

- A vulnerability was found in readelf; part of binutils.
A crafted executable or shared library could cause
use-after-free and out-of-bounds writes, leading to a
crash or possible code execution.(CVE-2017-6966)

Note that Tenable Network Security has extracted the preceding
description block directly from the EulerOS security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

Solution

Update the affected binutils packages.

See Also

http://www.nessus.org/u?033cd1e3

Plugin Details

Severity: Medium

ID: 117728

File Name: EulerOS_SA-2018-1284.nasl

Version: 1.2

Type: local

Published: 2018/09/27

Modified: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:binutils, p-cpe:/a:huawei:euleros:binutils-devel, cpe:/o:huawei:euleros:2.0

Patch Publication Date: 2018/09/04

Reference Information

CVE: CVE-2017-6965, CVE-2017-6966