Debian DLA-1522-1 : strongswan security update

High Nessus Plugin ID 117715

Synopsis

The remote Debian host is missing a security update.

Description

Sze Yiu Chau and his team from Purdue University and The University of Iowa found several security issues in the gmp plugin for strongSwan, an IKE/IPsec suite.

CVE-2018-16151

The OID parser in the ASN.1 code in gmp allows any number of random bytes after a valid OID.

CVE-2018-16152

The algorithmIdentifier parser in the ASN.1 code in gmp doesn't enforce a NULL value for the optional parameter which is not used with any PKCS#1 algorithm.

For Debian 8 'Jessie', these problems have been fixed in version 5.2.1-6+deb8u7.

We recommend that you upgrade your strongswan packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/09/msg00032.html

https://packages.debian.org/source/jessie/strongswan

Plugin Details

Severity: High

ID: 117715

File Name: debian_DLA-1522.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/09/27

Modified: 2018/09/27

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:charon-cmd, p-cpe:/a:debian:debian_linux:libcharon-extra-plugins, p-cpe:/a:debian:debian_linux:libstrongswan, p-cpe:/a:debian:debian_linux:libstrongswan-extra-plugins, p-cpe:/a:debian:debian_linux:libstrongswan-standard-plugins, p-cpe:/a:debian:debian_linux:strongswan, p-cpe:/a:debian:debian_linux:strongswan-charon, p-cpe:/a:debian:debian_linux:strongswan-dbg, p-cpe:/a:debian:debian_linux:strongswan-ike, p-cpe:/a:debian:debian_linux:strongswan-ikev1, p-cpe:/a:debian:debian_linux:strongswan-ikev2, p-cpe:/a:debian:debian_linux:strongswan-libcharon, p-cpe:/a:debian:debian_linux:strongswan-nm, p-cpe:/a:debian:debian_linux:strongswan-starter, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/09/26

Reference Information

CVE: CVE-2018-16151, CVE-2018-16152