Rockwell Automation RSLinx Classic <= 4.00.01 Multiple Vulnerabilities

High Nessus Plugin ID 117671

Synopsis

A SCADA application running on the remote host is affected by multiple vulnerabilities.

Description

The remote host has a version of RSLinx Classic installed that is v4.00.01 or prior. It is, therefore, affected by multiple vulnerabilities.

Solution

Patches are available for versions 4.00.01, 3.90.01, 3.81, 3.80, 3.74, and 3.60. See vendor Knowledgebase Article ID 1075712 for more details.

See Also

http://www.nessus.org/u?96fdfff6

https://ics-cert.us-cert.gov/advisories/ICSA-18-263-02

Plugin Details

Severity: High

ID: 117671

File Name: scada_rslinx_classic_4_00_01_multi_vulns.nbin

Version: 1.13

Type: local

Family: SCADA

Published: 2018/09/24

Updated: 2019/03/18

Dependencies: 83522

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-14829

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 10

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:rockwellautomation:rslinx_classic

Patch Publication Date: 2018/09/20

Vulnerability Publication Date: 2018/09/20

Reference Information

CVE: CVE-2018-14821, CVE-2018-14827, CVE-2018-14829

ICSA: 18-263-02

TRA: TRA-2018-26

IAVB: 2018-B-0127