Artifex Ghostscript < 9.25 PostScript Code Execution Vulnerability

High Nessus Plugin ID 117596

Synopsis

The remote Windows host contains a library that is affected by multiple vulnerabilities.

Description

The version of Artifex Ghostscript installed on the remote Windows host is prior to 9.25. It is, therefore, affected by a code execution vulnerability.

Solution

Update to 9.25.

See Also

https://ghostscript.com/doc/9.25/History9.htm

Plugin Details

Severity: High

ID: 117596

File Name: ghostscript_9_25.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 2018/09/19

Updated: 2019/04/05

Dependencies: 100357

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-16802

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 7.2

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:artifex:ghostscript, cpe:/a:artifex:gpl_ghostscript

Required KB Items: installed_sw/Ghostscript

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/09/13

Vulnerability Publication Date: 2018/09/03

Exploitable With

Metasploit (Ghostscript Failed Restore Command Execution)

Reference Information

CVE: CVE-2018-16509, CVE-2018-16802