Debian DSA-4296-1 : mbedtls - security update

Medium Nessus Plugin ID 117506

Synopsis

The remote Debian host is missing a security-related update.

Description

Two vulnerabilities were discovered in mbedtls, a lightweight crypto and SSL/TLS library which could result in plain text recovery via side-channel attacks.

Solution

Upgrade the mbedtls packages.

For the stable distribution (stretch), these problems have been fixed in version 2.4.2-1+deb9u3.

See Also

https://security-tracker.debian.org/tracker/source-package/mbedtls

https://packages.debian.org/source/stretch/mbedtls

https://www.debian.org/security/2018/dsa-4296

Plugin Details

Severity: Medium

ID: 117506

File Name: debian_DSA-4296.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2018/09/17

Updated: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:mbedtls, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/09/16

Reference Information

CVE: CVE-2018-0497, CVE-2018-0498

DSA: 4296