Pivotal Software Redis LUA < 3.2.12 / 4.0.x < 4.0.10 / 5.0 < 5.0rc2 Multiple Vulnerabilities

Medium Nessus Plugin ID 117484

Synopsis

Redis requires a security update.

Description

The version of Redis installed on the remote host is affected by multiple vulnerabilities and therefore requires a security update.

Solution

Update to Redis 3.2.12, 4.0.10 or 5.0-rc2 or higher.

See Also

http://antirez.com/news/119

Plugin Details

Severity: Medium

ID: 117484

File Name: redis_4_0_10.nasl

Version: 1.1

Type: remote

Family: Misc.

Published: 2018/09/14

Modified: 2018/09/14

Dependencies: 100635

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-12326

CVSS v2.0

Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.4

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:pivotal_software:redis

Patch Publication Date: 2018/06/14

Vulnerability Publication Date: 2018/06/14

Reference Information

CVE: CVE-2018-12326, CVE-2018-11218