Apache ActiveMQ 5.14.x - 5.15.2 OpenWire Information Disclosure

Medium Nessus Plugin ID 117482


A web application running on the remote host is affected by an
information disclosure vulnerability.


The version of Apache ActiveMQ running on the remote host is 5.15.4.x
or 5.14.x prior to 5.15.3. It is, therefore, affected by an
unspecified flaw related to the OpenWire protocol that allows
information disclosure.


Upgrade to Apache ActiveMQ version 5.15.3 or later.

Alternatively, use a TLS enabled transport.

See Also



Plugin Details

Severity: Medium

ID: 117482

File Name: activemq_5_15_3.nasl

Version: 1.1

Type: remote

Family: CGI abuses

Published: 2018/09/14

Modified: 2018/09/14

Dependencies: 45552

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2017-15709

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 3.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: cpe:/a:apache:activemq

Patch Publication Date: 2018/01/29

Vulnerability Publication Date: 2018/02/13

Reference Information

CVE: CVE-2017-15709