Debian DSA-4291-1 : mgetty - security update

High Nessus Plugin ID 117436

Synopsis

The remote Debian host is missing a security-related update.

Description

Two input sanitization failures have been found in the faxrunq and faxq binaries in mgetty, a smart modem getty replacement. An attacker could leverage them to insert commands via shell metacharacters in jobs id and have them executed with the privilege of the faxrunq/faxq user.

Solution

Upgrade the mgetty packages.

For the stable distribution (stretch), this problem has been fixed in version 1.1.36-3+deb9u1.

See Also

https://security-tracker.debian.org/tracker/mgetty

https://packages.debian.org/source/stretch/mgetty

http://www.debian.org/security/2018/dsa-4291

Plugin Details

Severity: High

ID: 117436

File Name: debian_DSA-4291.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/09/12

Modified: 2018/09/12

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:mgetty, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/09/11

Reference Information

CVE: CVE-2018-16741

DSA: 4291