Debian DSA-4290-1 : libextractor - security update

Medium Nessus Plugin ID 117435

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities were discovered in libextractor, a library to extract arbitrary meta-data from files, which may lead to denial of service or the execution of arbitrary code if a specially crafted file is opened.

Solution

Upgrade the libextractor packages.

For the stable distribution (stretch), these problems have been fixed in version 1:1.3-4+deb9u2.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=904903

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=904905

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=907987

http://www.nessus.org/u?bd14df80

https://packages.debian.org/source/stretch/libextractor

https://www.debian.org/security/2018/dsa-4290

Plugin Details

Severity: Medium

ID: 117435

File Name: debian_DSA-4290.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2018/09/12

Modified: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libextractor, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/09/10

Reference Information

CVE: CVE-2018-14346, CVE-2018-14347, CVE-2018-16430

DSA: 4290