Debian DLA-1502-1 : mgetty security update

High Nessus Plugin ID 117434

Synopsis

The remote Debian host is missing a security update.

Description

Two input sanitization failures have been found in the faxrunq and faxq binaries in mgetty. An attacker could leverage them to insert commands via shell metacharacters in jobs id and have them executed with the privilege of the faxrunq/faxq user.

For Debian 8 'Jessie', this problem has been fixed in version 1.1.36-2.1+deb8u1.

We recommend that you upgrade your mgetty packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/09/msg00012.html

https://packages.debian.org/source/jessie/mgetty

Plugin Details

Severity: High

ID: 117434

File Name: debian_DLA-1502.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/09/12

Modified: 2018/11/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:mgetty, p-cpe:/a:debian:debian_linux:mgetty-docs, p-cpe:/a:debian:debian_linux:mgetty-fax, p-cpe:/a:debian:debian_linux:mgetty-pvftools, p-cpe:/a:debian:debian_linux:mgetty-viewfax, p-cpe:/a:debian:debian_linux:mgetty-voice, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/09/12

Reference Information

CVE: CVE-2018-16741