NUUO NVRMini2 Multiple Vulnerabilities

Critical Nessus Plugin ID 117427

Synopsis

The remote host is affected by multiple vulnerabilities.

Description

The version of NUUO NVRMini2 installed on the remote host is affected by multiple vulnerabilities:

- NUUO NVRMini2 web server utilizes CGI binaries in order to handle a variety of commands that require authenticated interaction.
Implemented session handling mechanism doesn't validate user's input properly. Malicious attackers can trigger stack overflow in session management routines in order to execute arbitrary code. (CVE-2018-1149)

- NUUO NVRMini2 web server contains back door functionality. Back door PHP code (when enabled) allows unauthenticated attacker to change a password for any registered user except administrator of the system. (CVE-2018-1150)

Solution

All users of NUUO NVRMini2 should upgrade to version 3.9.1 (03.09.0001.0000) or later. Otherwise, contact the vendor for a fix.

Plugin Details

Severity: Critical

ID: 117427

File Name: nuuo_multiple_vulnerabilities.nasl

Version: 1.4

Type: remote

Family: Misc.

Published: 2018/09/17

Modified: 2018/09/17

Dependencies: 103929

Risk Information

Risk Factor: Critical

CVSS Score Source: CVE-2018-1149

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 10

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/o:nuuo:nvrmini_2

Required KB Items: installed_sw/NUUO NVR

Patch Publication Date: 2018/09/17

Vulnerability Publication Date: 2018/09/17

Reference Information

CVE: CVE-2018-1149, CVE-2018-1150