Apache Struts 2.x < 2.3.1.1 Multiple Critical Vulnerabilities (S2-008)

Critical Nessus Plugin ID 117404

Synopsis

A web application running on the remote host uses a Java framework that is affected by multiple critical vulnerabilities.

Description

The version of Apache Struts running on the remote host is 2.x prior to 2.3.1.1. It, therefore, is affected by multiple critical vulnerabilities, including a possible remote command execution vulnerability.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.3.1.1 or later

See Also

https://cwiki.apache.org/confluence/display/WW/S2-008

Plugin Details

Severity: Critical

ID: 117404

File Name: struts_2_3_1_1.nasl

Version: 1.1

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/11

Modified: 2018/09/11

Dependencies: 73943, 99671, 11936

Risk Information

Risk Factor: Critical

CVSS Score Source: manual

CVSS Score Rationale: Remote command execution

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Patch Publication Date: 2012/01/02

Vulnerability Publication Date: 2012/01/02