Apache Struts 2.x < 2.3.1.2 RCE (S2-009)

Critical Nessus Plugin ID 117403

Synopsis

A web application running on the remote host uses a Java framework that is affected by a remote command execution vulnerability.

Description

The version of Apache Struts running on the remote host is 2.x prior to 2.3.1.2. It, therefore, is affected a possible remote command execution vulnerability.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.3.1.2 or later

See Also

https://cwiki.apache.org/confluence/display/WW/S2-009

Plugin Details

Severity: Critical

ID: 117403

File Name: struts_2_3_1_2.nasl

Version: 1.3

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/11

Modified: 2018/09/17

Dependencies: 99671, 11936, 73943

Risk Information

Risk Factor: Critical

CVSS Score Source: manual

CVSS Score Rationale: Remote command execution

CVSSv2

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/01/19

Vulnerability Publication Date: 2012/01/19

Exploitable With

CANVAS (White_Phosphorus)

Metasploit (Apache Struts ParametersInterceptor Remote Code Execution)

Elliot (Apache-Struts ParameterInterceptor < 2.3.1.2 RCE Linux)

Reference Information

CVE: CVE-2011-3923

BID: 51628