Apache Struts 2.x < 2.3.14.1 Multiple RCE Vulnerabilities (S2-012) (S2-013)

High Nessus Plugin ID 117401

Synopsis

A web application running on the remote host uses a Java framework
that is affected by multiple remote command execution
vulnerabilities.

Description

The version of Apache Struts running on the remote host is 2.x
prior to 2.3.14.1. It, therefore, is affected by multiple
remote command execution vulnerabilities.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.3.14.1 or later

See Also

https://cwiki.apache.org/confluence/display/WW/S2-012

https://cwiki.apache.org/confluence/display/WW/S2-013

Plugin Details

Severity: High

ID: 117401

File Name: struts_2_3_14_1.nasl

Version: 1.5

Type: combined

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/11

Modified: 2019/02/15

Dependencies: 73943, 99671, 122235, 11936

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2013-1965

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apache:struts

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/04/16

Vulnerability Publication Date: 2013/04/16

Exploitable With

Core Impact

Metasploit (Apache Struts includeParams Remote Code Execution)

Elliot (Apache-Struts Showcase < 2.3.14.1 RCE Linux)

Reference Information

CVE: CVE-2013-1965, CVE-2013-1966

BID: 60082, 60166