Apache Struts 2.x < 2.3.4.1 Multiple Vulnerabilities (S2-010) (S2-011)

Medium Nessus Plugin ID 117400

Synopsis

A web application running on the remote host uses a Java framework
that is affected by multiple vulnerabilities.

Description

The version of Apache Struts running on the remote host is 2.x
prior to 2.3.4.1. It, therefore, is affected by multiple
vulnerabilities including a Denial of Service (DoS) and cross-site
request forgery (XSRF) vulnerabilities.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.3.4.1 or later

See Also

https://cwiki.apache.org/confluence/display/WW/S2-010

https://cwiki.apache.org/confluence/display/WW/S2-011

Plugin Details

Severity: Medium

ID: 117400

File Name: struts_2_3_4_1.nasl

Version: 1.5

Type: combined

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/11

Modified: 2019/02/15

Dependencies: 122235, 11936, 73943, 99671

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2012-4386

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:apache:struts

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/08/03

Vulnerability Publication Date: 2012/08/03

Reference Information

CVE: CVE-2012-4386, CVE-2012-4387

BID: 54346, 55346