Apache Struts 2.x < 18.104.22.168 Multiple Vulnerabilities (S2-010) (S2-011)
Medium Nessus Plugin ID 117400
SynopsisA web application running on the remote host uses a Java framework
that is affected by multiple vulnerabilities.
DescriptionThe version of Apache Struts running on the remote host is 2.x
prior to 22.214.171.124. It, therefore, is affected by multiple
vulnerabilities including a Denial of Service (DoS) and cross-site
request forgery (XSRF) vulnerabilities.
Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.
SolutionUpgrade to Apache Struts version 126.96.36.199 or later