Apache Struts 2.x < 184.108.40.206 Multiple Vulnerabilities (S2-020)
High Nessus Plugin ID 117393
SynopsisA web application running on the remote host uses a Java framework that is affected by multiple vulnerabilities.
DescriptionThe version of Apache Struts running on the remote host is 2.x prior to 220.127.116.11. It, therefore, is affected by multiple vulnerabilities including a denial of service (DoS) vulnerability and a ClassLoader manipulation flaw.
Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
SolutionUpgrade to Apache Struts version 18.104.22.168 or later