Apache Struts 2.x < 2.3.16.1 Multiple Vulnerabilities (S2-020)

High Nessus Plugin ID 117393

Synopsis

A web application running on the remote host uses a Java framework that is affected by multiple vulnerabilities.

Description

The version of Apache Struts running on the remote host is 2.x prior to 2.3.16.1. It, therefore, is affected by multiple vulnerabilities including a denial of service (DoS) vulnerability and a ClassLoader manipulation flaw.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.3.16.1 or later

See Also

https://cwiki.apache.org/confluence/display/WW/S2-020

Plugin Details

Severity: High

ID: 117393

File Name: struts_2_3_16_1.nasl

Version: 1.3

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/10

Modified: 2018/09/17

Dependencies: 99671, 11936, 73943

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2014-0050

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/03/01

Vulnerability Publication Date: 2014/03/01

Exploitable With

Core Impact

Metasploit (Apache Struts ClassLoader Manipulation Remote Code Execution)

Reference Information

CVE: CVE-2014-0050, CVE-2014-0094

BID: 65400, 65999