Apache Struts 2.x < 2.2.3.1 RCE (S2-007)

Critical Nessus Plugin ID 117392

Synopsis

A web application running on the remote host uses a Java framework that is affected by a possible remote code execution.

Description

The version of Apache Struts running on the remote host is 2.x prior to 2.2.3.1. It, therefore, is affected by a possible remote code execution vulnerability when user-supplied input is evaluated as an OGNL expressions when there is a conversion error.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.2.3.1 or later

See Also

https://cwiki.apache.org/confluence/display/WW/S2-007

Plugin Details

Severity: Critical

ID: 117392

File Name: struts_2_2_3_1.nasl

Version: 1.1

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/10

Modified: 2018/09/10

Dependencies: 99671, 73943, 11936

Risk Information

Risk Factor: Critical

CVSS Score Source: manual

CVSS Score Rationale: Remote code execution

CVSSv2

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSSv3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Patch Publication Date: 2011/09/09

Vulnerability Publication Date: 2011/09/09