Apache Struts 2.x < 2.3.15.3 Broken Access Control Vulnerability (S2-018)

Medium Nessus Plugin ID 117391

Synopsis

A web application running on the remote host uses a Java framework that is affected by a broken access control vulnerability.

Description

The version of Apache Struts running on the remote host is 2.x prior to 2.3.15.3. It, therefore, is affected by a broken access control vulnerability which can be used to bypass security constraints.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.3.15.3 or later or follow the vendors instructions to disable DMI.

See Also

https://cwiki.apache.org/confluence/display/WW/S2-018

Plugin Details

Severity: Medium

ID: 117391

File Name: struts_2_3_15_3.nasl

Version: 1.3

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/10

Modified: 2018/09/17

Dependencies: 99671, 11936, 73943

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2013-4310

CVSS v2.0

Base Score: 5.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/09/06

Vulnerability Publication Date: 2013/09/06

Reference Information

CVE: CVE-2013-4310

BID: 62584