Apache Struts 2.0.x < 2.0.12 Multiple Vulnerabilities (S2-003) (S2-004)

Critical Nessus Plugin ID 117390


A web application running on the remote host uses a Java framework
that is affected by multiple vulnerabilities.


The version of Apache Struts running on the remote host is 2.0.x
prior to 2.0.12. It, therefore, is affected by a possible
OGNL expression execution vulnerability due to improper validation
of user-supplied by the ParameterInterceptor class. Additionally,
the application may also be affected by a possible directory
traversal vulnerability.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.


Upgrade to Apache Struts version 2.0.12 or later

See Also



Plugin Details

Severity: Critical

ID: 117390

File Name: struts_2_0_12.nasl

Version: 1.2

Type: combined

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/10

Modified: 2019/02/15

Dependencies: 73943, 99671, 122235, 11936

Risk Information

Risk Factor: Critical

CVSS Score Source: manual

CVSS Score Rationale: Ognl execution

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apache:struts

Patch Publication Date: 2007/06/22

Vulnerability Publication Date: 2008/06/22