Apache Struts 2.x < 2.2.3 Multiple XSS (S2-006)

Medium Nessus Plugin ID 117388


A web application running on the remote host uses a Java framework that is affected by multiple cross-site scripting vulnerabilities.


The version of Apache Struts running on the remote host is 2.x prior to 2.2.3. It, therefore, is affected by multiple cross-site scripting (XSS) vulnerabilities due to improper validation of action names.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Struts version 2.2.3 or later

See Also


Plugin Details

Severity: Medium

ID: 117388

File Name: struts_2_2_3.nasl

Version: 1.3

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/10

Modified: 2018/09/17

Dependencies: 99671, 73943, 11936

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Cross-site scripting

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/05/09

Vulnerability Publication Date: 2011/05/09

Reference Information

CVE: CVE-2011-1772

BID: 47784