Apache Struts 2.0.x < 2.2.1 <s:url> and <s:a> Tag XSS (S2-002)

medium Nessus Plugin ID 117387


A web application running on the remote host uses a Java framework that is affected by a cross-site scripting vulnerability.


The version of Apache Struts running on the remote host is 2.0.x prior to 2.2.1. It is, therefore, affected by a possible cross-site scripting (XSS) vulnerability due to improper validation of user-supplied input to <s:url> and <s:a> tags. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Struts version 2.2.1 or later

See Also


Plugin Details

Severity: Medium

ID: 117387

File Name: struts_2_0_11_1.nasl

Version: 1.5

Type: combined

Agent: windows, macosx, unix

Family: Misc.

Published: 9/10/2018

Updated: 4/11/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information

CVSS Score Rationale: Cross-site scripting


Risk Factor: Medium

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS Score Source: manual


Risk Factor: Medium

Base Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:apache:struts

Patch Publication Date: 3/3/2008

Vulnerability Publication Date: 3/3/2008