Apache Struts 2.0.x < 2.0.11.1 <s:url> and <s:a> Tag XSS (S2-002)

Medium Nessus Plugin ID 117387

Synopsis

A web application running on the remote host uses a Java framework that is affected by a cross-site scripting vulnerability.

Description

The version of Apache Struts running on the remote host is 2.0.x prior to 2.0.11.1. It, therefore, is affected by a possible cross-site scripting (XSS) vulnerability due to improper validation of user-supplied input to <s:url> and <s:a> tags.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.0.11.1 or later

See Also

https://cwiki.apache.org/confluence/display/WW/S2-002

Plugin Details

Severity: Medium

ID: 117387

File Name: struts_2_0_11_1.nasl

Version: 1.1

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/10

Modified: 2018/09/10

Dependencies: 73943, 99671, 11936

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Cross-site scripting

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Patch Publication Date: 2008/03/03

Vulnerability Publication Date: 2008/03/03