Apache Struts 2.0.x < 2.0.9 RCE (S2-001)

Critical Nessus Plugin ID 117365


A web application running on the remote host uses a Java framework that is affected by a possible remote code execution.


The version of Apache Struts running on the remote host is 2.0.x prior to 2.0.9. It, therefore, is affected by a possible remote code execution vulnerability when OGNL expressions are evaluated in a form field.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Struts version 2.0.9 or later

See Also


Plugin Details

Severity: Critical

ID: 117365

File Name: struts_2_0_9.nasl

Version: 1.1

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/10

Modified: 2018/09/10

Dependencies: 11936, 99671, 73943

Risk Information

Risk Factor: Critical

CVSS Score Source: manual

CVSS Score Rationale: Remote code execution

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Patch Publication Date: 2007/07/16

Vulnerability Publication Date: 2007/07/16