Apache Struts 2.x < 2.3.14.2 Multiple Vulnerabilities (S2-014)

High Nessus Plugin ID 117364

Synopsis

A web application running on the remote host uses a Java framework that is affected by multiple vulnerabilities.

Description

The version of Apache Struts running on the remote host is 2.x prior to 2.3.14.2. It, therefore, is affected by multiple vulnerabilities including a remote command execution vulnerability and a cross-site scripting (XSS) vulnerability.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.3.14.2 or later

See Also

https://cwiki.apache.org/confluence/display/WW/S2-014

Plugin Details

Severity: High

ID: 117364

File Name: struts_2_3_14_2.nasl

Version: 1.3

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/10

Modified: 2018/09/17

Dependencies: 11936, 99671, 73943

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2013-2115

CVSSv2

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/05/26

Vulnerability Publication Date: 2013/05/26

Exploitable With

Core Impact

Metasploit (Apache Struts includeParams Remote Code Execution)

Elliot (Apache-Struts IncludeParams < 2.3.14.1 RCE Linux)

Reference Information

CVE: CVE-2013-1966, CVE-2013-2115

BID: 60166, 60167