Apache Struts 2.x < 188.8.131.52 Multiple Vulnerabilities (S2-014)
High Nessus Plugin ID 117364
SynopsisA web application running on the remote host uses a Java framework that is affected by multiple vulnerabilities.
DescriptionThe version of Apache Struts running on the remote host is 2.x prior to 184.108.40.206. It, therefore, is affected by multiple vulnerabilities including a remote command execution vulnerability and a cross-site scripting (XSS) vulnerability.
Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
SolutionUpgrade to Apache Struts version 220.127.116.11 or later