Apache Struts 2.x < 2.2.1 OGNL RCE (S2-005)

medium Nessus Plugin ID 117363


A web application running on the remote host uses a Java framework that is affected by a possible remote code execution.


The version of Apache Struts running on the remote host is 2.x prior to 2.2.1. It, therefore, is affected by a possible remote code execution vulnerability when OGNL expressions are evaluated due to improper validation by the ParametersInterceptor class.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Struts version 2.2.1 or later

See Also



Plugin Details

Severity: Medium

ID: 117363

File Name: struts_2_2_1.nasl

Version: 1.11

Type: combined

Agent: windows, macosx, unix

Family: Misc.

Published: 9/10/2018

Updated: 4/11/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: High

Score: 7.4


Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

CVSS Score Source: CVE-2010-1870


Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:struts

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 8/15/2010

Vulnerability Publication Date: 8/15/2010

Exploitable With

CANVAS (White_Phosphorus)

Core Impact

Metasploit (Apache Struts Remote Command Execution)

Elliot (Apache-Struts < 2.2.0 RCE Linux)

Reference Information

CVE: CVE-2010-1870

BID: 41592