Apache Struts 2.x < 2.2.1 OGNL RCE (S2-005)

Medium Nessus Plugin ID 117363

Synopsis

A web application running on the remote host uses a Java framework that is affected by a possible remote code execution.

Description

The version of Apache Struts running on the remote host is 2.x prior to 2.2.1. It, therefore, is affected by a possible remote code execution vulnerability when OGNL expressions are evaluated due to improper validation by the ParametersInterceptor class.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.2.1 or later

See Also

http://blog.o0o.nu/2010/07/cve-2010-1870-struts2xwork-remote.html

https://cwiki.apache.org/confluence/display/WW/S2-005

Plugin Details

Severity: Medium

ID: 117363

File Name: struts_2_2_1.nasl

Version: 1.3

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/10

Modified: 2018/09/17

Dependencies: 99671, 11936, 73943

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2010-1870

CVSS v2.0

Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

CVSS v3.0

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/08/15

Vulnerability Publication Date: 2010/08/15

Exploitable With

CANVAS (White_Phosphorus)

Core Impact

Metasploit (Apache Struts Remote Command Execution)

Elliot (Apache-Struts < 2.2.0 RCE Linux)

Reference Information

CVE: CVE-2010-1870

BID: 41592