Apache Struts 2.x < 2.3.15.1 Multiple Vulnerabilities (S2-016) (S2-017)

High Nessus Plugin ID 117362

Synopsis

A web application running on the remote host uses a Java framework that is affected by multiple vulnerabilities.

Description

The version of Apache Struts running on the remote host is 2.x prior to 2.3.15.1. It, therefore, is affected by multiple vulnerabilities including a remote command execution vulnerability and an open redirect vulnerability.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.3.15.1 or later

See Also

https://cwiki.apache.org/confluence/display/WW/S2-016

https://cwiki.apache.org/confluence/display/WW/S2-017

Plugin Details

Severity: High

ID: 117362

File Name: struts_2_3_15_1.nasl

Version: 1.4

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/10

Modified: 2018/09/17

Dependencies: 99671, 73943, 11936

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2013-2251

CVSSv2

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/07/09

Vulnerability Publication Date: 2013/07/09

Exploitable With

CANVAS (D2ExploitPack)

Core Impact

Metasploit (Apache Struts 2 DefaultActionMapper Prefixes OGNL Code Execution)

Elliot (Apache-Struts DefaultActionMapper < 2.3.15.1 RCE Linux)

Reference Information

CVE: CVE-2013-2248, CVE-2013-2251

BID: 61189, 61196