Docker for Windows stable < 18.06.0-ce-win70 / edge < 18.06.0-ce-rc3-win68 Remote Privilege Escalation Vulnerability

High Nessus Plugin ID 117358

Synopsis

The remote host has an application installed that is affected by a remote privilege escalation vulnerability.

Description

The version of Docker for Windows installed on the remote Windows host is stable channel < 18.06.0-ce-win70 or edge channel < 18.06.0-ce-rc3-win68. It is, therefore, affected by a remote privilege escalation vulnerability.

Solution

Upgrade to Docker for Windows stable 18.06.0-ce-win70 or edge 18.06.0-ce-rc3-win68 or later.

See Also

http://www.nessus.org/u?6032ba75

https://docs.docker.com/docker-for-windows/release-notes/

https://docs.docker.com/docker-for-windows/edge-release-notes/

Plugin Details

Severity: High

ID: 117358

File Name: docker_for_windows_CVE-2018-15514.nasl

Version: 1.1

Type: local

Agent: windows

Family: Windows

Published: 2018/09/07

Modified: 2018/09/07

Dependencies: 117359

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-15514

CVSS v2.0

Base Score: 8.5

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:docker:docker

Required KB Items: installed_sw/Docker for Windows, SMB/Registry/Enumerated

Patch Publication Date: 2018/07/19

Vulnerability Publication Date: 2018/08/18

Reference Information

CVE: CVE-2018-15514

BID: 105202

IAVA: 2018-A-0283