Debian DLA-1494-1 : gdm3 security update

High Nessus Plugin ID 117295

Synopsis

The remote Debian host is missing a security update.

Description

The daemon in GDM does not properly unexport display objects from its D-Bus interface when they are destroyed, which allows a local attacker to trigger a use-after-free via a specially crafted sequence of D-Bus method calls, resulting in a denial of service or potential code execution.

For Debian 8 'Jessie', this problem has been fixed in version 3.14.1-7+deb8u1.

We recommend that you upgrade your gdm3 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/09/msg00003.html

https://packages.debian.org/source/jessie/gdm3

Plugin Details

Severity: High

ID: 117295

File Name: debian_DLA-1494.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/09/06

Modified: 2018/09/06

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:gdm3, p-cpe:/a:debian:debian_linux:gir1.2-gdm3, p-cpe:/a:debian:debian_linux:libgdm-dev, p-cpe:/a:debian:debian_linux:libgdm1, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/09/05

Reference Information

CVE: CVE-2018-14424