LeapFTP < 2.7.4.x PASV Reply Remote Overflow

High Nessus Plugin ID 11705


The remote host is running an FTP client that is affected by a buffer overflow vulnerability.


The remote host is running LeapFTP - an FTP client.

There is a flaw in the remote version of this software that could allow an attacker to execute arbitrary code on this host.

To exploit it, an attacker would need to set up a rogue FTP server and have a user on this host connect to it.


Upgrade to version 2.7.4.x or newer as this reportedly fixes the issue.

See Also


Plugin Details

Severity: High

ID: 11705

File Name: leapftp_overflow.nasl

Version: $Revision: 1.16 $

Type: local

Agent: windows

Family: Windows

Published: 2003/06/09

Modified: 2015/01/12

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Required KB Items: SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2003/06/09

Exploitable With

Metasploit (LeapWare LeapFTP v2.7.3.600 PASV Reply Client Overflow)

Reference Information

BID: 7860

OSVDB: 4587