Samba < 2.2.8a / 3.0.0 Multiple Remote Overflows

Critical Nessus Plugin ID 11523


Arbitrary code may be run on the remote server.


The remote Samba server is vulnerable to a buffer overflow when it calls the function trans2open(). An attacker may exploit this flaw to gain a root shell on this host.

In addition, it is reported that this version of Samba is vulnerable to additional overflows, although Nessus has not checked for them.


Upgrade to Samba 2.2.8a or 3.0.0.

Plugin Details

Severity: Critical

ID: 11523

File Name: samba_trans2open_overflow.nasl

Version: $Revision: 1.31 $

Type: remote

Published: 2003/04/07

Modified: 2017/08/15

Dependencies: 10785

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/samba, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2003/04/07

Exploitable With


Metasploit (Samba trans2open Overflow (Solaris SPARC))

Reference Information

CVE: CVE-2003-0196, CVE-2003-0201

BID: 7294, 7295

OSVDB: 4469, 13397

RHSA: 2003:137-02

SuSE: SUSE-SA:2003:025