Apache 2.0.x < 2.0.45 Multiple Vulnerabilities (DoS, File Write)

Medium Nessus Plugin ID 11507


The remote web server is affected by multiple vulnerabilities.


The remote host is running a version of Apache 2.0.x that is prior to 2.0.45. It is, therefore, reportedly affected by multiple vulnerabilities :

- There is a denial of service attack that could allow an attacker to disable this server remotely.

- The httpd process leaks file descriptors to child processes, such as CGI scripts. An attacker who has the ability to execute arbitrary CGI scripts on this server (including PHP code) would be able to write arbitrary data in the file pointed to (in particular, the log files).


Upgrade to Apache web server version 2.0.45 or later.

See Also


Plugin Details

Severity: Medium

ID: 11507

File Name: apache_2_0_45.nasl

Version: $Revision: 1.36 $

Type: remote

Family: Web Servers

Published: 2003/04/03

Modified: 2018/01/22

Dependencies: 48204, 10386

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2003/04/02

Reference Information

CVE: CVE-2003-0132

BID: 7254, 7255

OSVDB: 9712, 56517