QuickTime < 6.1 URL Handling Overflow (Windows)

High Nessus Plugin ID 11506


Arbitrary code may be run on the remote host.


The remote version of the QuickTime player is vulnerable to a buffer overflow.

To exploit it, an attacker would need a user of this host to visit a rogue webpage with a malformed link in it. He could then be able to execute arbitrary code with the rights of the user visiting the page.


Upgrade to QuickTime Player version 6.1 or later.

Plugin Details

Severity: High

ID: 11506

File Name: quicktime_player_overflow.nasl

Version: $Revision: 1.16 $

Type: local

Agent: windows

Family: Windows

Published: 2003/04/02

Modified: 2011/04/13

Dependencies: 21561

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:quicktime

Required KB Items: SMB/QuickTime/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2003/03/31

Reference Information

CVE: CVE-2003-0168

BID: 7247

OSVDB: 10561