Sendmail < 8.12.9 NOCHAR Control Value prescan Overflow

Critical Nessus Plugin ID 11499


Arbitrary code may be run on the remote server


The remote sendmail server, according to its version number, may be vulnerable to a remote buffer overflow allowing remote users to gain root privileges.

Sendmail versions from 5.79 to 8.12.8 are vulnerable.

NOTE: manual patches do not change the version numbers.
Vendors who have released patched versions of sendmail may still falsely show vulnerability.

*** Nessus reports this vulnerability using only the banner of the
*** remote SMTP server. Therefore, this might be a false positive.


Upgrade to Sendmail ver 8.12.9 or greater or if you cannot upgrade, apply patches for 8.10-12 here:

Plugin Details

Severity: Critical

ID: 11499

File Name: sendmail_conversion_overflow.nasl

Version: $Revision: 1.27 $

Type: remote

Published: 2003/03/29

Modified: 2014/05/02

Dependencies: 11936, 10263, 13350, 13541, 13454, 13592, 13225, 13121

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:sendmail:sendmail

Required KB Items: SMTP/sendmail

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2003/03/29

Reference Information

CVE: CVE-2003-0161

BID: 7230

OSVDB: 8294

RHSA: 2003:120-01