APC < 3.8.0 apcupsd Multiple Vulnerabilities

Critical Nessus Plugin ID 11484


The remote host is running an application which is affected by multiple vulnerabilities.


The remote host is running the apcupsd client which, according to its version number, is affected by multiple vulnerabilities :

- The configuration file '/var/run/apcupsd.pid' is by default world-writable. A local attacker could re-write this file with other process IDs in order to crash the affected system.

- An issue exists in the 'log_event' function which a local attacker could exploit in order to execute arbitrary code.

- Several buffer overflow vulnerabilities have been reported which a remote attacker could exploit in order to execute arbitrary code on the remote host.

*** Nessus solely relied on the version number of the
*** remote server, so this might be a false positive


Upgrading to acpupsd version 3.8.0 or newer reportedly fixes the issue.

See Also



Plugin Details

Severity: Critical

ID: 11484

File Name: apcupsd_overflows.nasl

Version: $Revision: 1.18 $

Type: remote

Published: 2003/03/26

Modified: 2016/11/11

Dependencies: 11483, 17975

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2000/12/06

Reference Information

CVE: CVE-2001-0040, CVE-2003-0098, CVE-2003-0099

BID: 2070, 6828, 7200

OSVDB: 1683, 10748, 10749