Sun rpc.cmsd Remote Overflow

Critical Nessus Plugin ID 11418


Arbitrary code may be run on the remote server.


The remote Sun rpc.cmsd has integer overflow problem in xdr_array. An attacker may use this flaw to execute arbitrary code on this host with the privileges rpc.cmsd is running as (typically, root), by sending a specially crafted request to this service.


We suggest that you disable this service and apply a new patch.

Plugin Details

Severity: Critical

ID: 11418

File Name: rpc_cmsd_overflow.nasl

Version: $Revision: 1.22 $

Type: remote

Family: RPC

Published: 2003/03/19

Modified: 2017/02/16

Dependencies: 10223

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 9.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:ND/RC:ND

Vulnerability Information

Required KB Items: rpc/portmap, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2002/08/01

Exploitable With


Reference Information

CVE: CVE-2002-0391

BID: 5356

OSVDB: 16003