Opera < 7.03 Multiple Vulnerabilities

High Nessus Plugin ID 11404


The remote host has an application that is affected by multiple flaws.


The version of Opera installed on the remote host is vulnerable to various security flaws, ranging from cross-site scripting to buffer overflows.

To exploit them, an attacker would need to set up a rogue website, then lure a user of this host visit it using Opera. He would then be able to execute arbitrary code on this host.


Install Opera 7.03 or newer.

See Also


Plugin Details

Severity: High

ID: 11404

File Name: opera_multiple_flaws.nasl

Version: $Revision: 1.23 $

Type: local

Agent: windows

Family: Windows

Published: 2003/03/16

Modified: 2016/12/07

Dependencies: 21746

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:U/RC:C

Vulnerability Information

CPE: cpe:/a:opera:opera_browser

Required KB Items: SMB/Opera/Version

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2003/02/26

Reference Information

CVE: CVE-2002-2414, CVE-2003-1387, CVE-2003-1397, CVE-2003-1420

BID: 6218, 6754, 6755, 6756, 6757, 6759, 6811, 6814, 6962, 7056

OSVDB: 17580, 60253, 60369, 60372

CWE: 79, 119