Gupta SQLBase EXECUTE Command Remote Overflow

High Nessus Plugin ID 11363


The remote SQL server is affected by a buffer overflow vulnerability.


The remote host is running a version of the Gupta SQLBase server which is older than or equal to 8.1.0.

An error in the 'Execute' command makes it possible to trigger a buffer overflow by supplying more than 700 characters as the parameter. A remote, authenticated attacker, exploiting this flaw, can crash the affected service or potentially execute arbitrary code with SYSTEM privileges.


There is no known solution at this time.

Plugin Details

Severity: High

ID: 11363

File Name: gupta_sqlbase_overflows.nasl

Version: $Revision: 1.16 $

Type: local

Agent: windows

Family: Windows

Published: 2003/03/12

Modified: 2015/01/12

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 8.5

Temporal Score: 7.2

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:U/RC:ND

Vulnerability Information

Required KB Items: SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2003-1393

BID: 6808

OSVDB: 59067

Secunia: 8023

CWE: 119