RHEL 7 : ansible (RHSA-2017:1685)

High Nessus Plugin ID 112261

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

An update for ansible is now available for RHEV Engine version 4.1.

Red Hat Product Security has rated this update as having a security
impact of Important. A Common Vulnerability Scoring System (CVSS) base
score, which gives a detailed severity rating, is available for each
vulnerability from the CVE link(s) in the References section.

Ansible is a simple model-driven configuration management, multi-node
deployment, and remote-task execution system. Ansible works over SSH
and does not require any software or daemons to be installed on remote
nodes. Extension modules can be written in any language and are
transferred to managed machines automatically.

The following packages have been upgraded to a later upstream version:
ansible (2.3.0.0). (BZ#1446527)

Security Fix(es) :

* An input validation vulnerability was found in Ansible's handling of
data sent from client systems. An attacker with control over a client
system being managed by Ansible and the ability to send facts back to
the Ansible server could use this flaw to execute arbitrary code on
the Ansible server using the Ansible server privileges.
(CVE-2016-9587)

* An input validation vulnerability was found in Ansible's handling of
data sent from client systems. An attacker with control over a client
system being managed by Ansible, and the ability to send facts back to
the Ansible server, could use this flaw to execute arbitrary code on
the Ansible server using the Ansible server privileges.
(CVE-2017-7466)

* An input validation vulnerability was found in Ansible's mysql_user
module which may fail to correctly change a password in certain
circumstances. Thus the previous password would still be active when
it should have been changed. (CVE-2016-8647)

The CVE-2017-7466 issue was discovered by Evgeni Golov (Red Hat).

Solution

Update the affected ansible and / or ansible-doc packages.

See Also

https://access.redhat.com/errata/RHSA-2017:1685

https://access.redhat.com/security/cve/cve-2016-8647

https://access.redhat.com/security/cve/cve-2016-9587

https://access.redhat.com/security/cve/cve-2017-7466

Plugin Details

Severity: High

ID: 112261

File Name: redhat-RHSA-2017-1685.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/09/04

Modified: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:ansible, p-cpe:/a:redhat:enterprise_linux:ansible-doc, cpe:/o:redhat:enterprise_linux:7

Patch Publication Date: 2017/07/17

Reference Information

CVE: CVE-2016-8647, CVE-2016-9587, CVE-2017-7466

RHSA: 2017:1685