Debian DSA-4283-1 : ruby-json-jwt - security update

Medium Nessus Plugin ID 112233

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that ruby-json-jwt, a Ruby implementation of JSON web tokens performed insufficient validation of GCM auth tags.

Solution

Upgrade the ruby-json-jwt packages.

For the stable distribution (stretch), this problem has been fixed in version 1.6.2-1+deb9u1.

See Also

http://www.nessus.org/u?0f0dbb2d

https://packages.debian.org/source/stretch/ruby-json-jwt

https://www.debian.org/security/2018/dsa-4283

Plugin Details

Severity: Medium

ID: 112233

File Name: debian_DSA-4283.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2018/09/04

Modified: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ruby-json-jwt, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/08/31

Reference Information

CVE: CVE-2018-1000539

DSA: 4283